Adds a new named option to the options structure.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public void AddOption( string name, string value ) |
Visual Basic |
---|
Public Sub AddOption ( _ name As String, _ value As String _ ) |
Visual C++ |
---|
public: void AddOption( String^ name, String^ value ) |
Parameters
- name
- Type: System..::..String
The option name.
- value
- Type: System..::..String
The option value.
Remarks
Named options can be used to set options not accessible through the standard IFC export user interface.
It is up to the implementation of the IExporterIFC interface to customize export behavior based on these options.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |