Determine whether two Grids are members of the same GridChain.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public static bool AreGridsInSameMultiSegmentGrid(
	Grid grid1,
	Grid grid2
)
Visual Basic
Public Shared Function AreGridsInSameMultiSegmentGrid ( _
	grid1 As Grid, _
	grid2 As Grid _
) As Boolean
Visual C++
public:
static bool AreGridsInSameMultiSegmentGrid(
	Grid^ grid1, 
	Grid^ grid2
)

Parameters

grid1
Type: Autodesk.Revit.DB..::..Grid
A Grid.
grid2
Type: Autodesk.Revit.DB..::..Grid
A Grid.

Return Value

Returns true if both of the specified Grids are associated to the same MultiSegmentGrid, i.e. getMultiSegementGridId returns the same valid element id for both Grids.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also