Returns all Parts that are associated with the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public static ICollection<ElementId> GetAssociatedParts(
	Document hostDocument,
	ElementId elementId,
	bool includePartsWithAssociatedParts,
	bool includeAllChildren
)
Visual Basic
Public Shared Function GetAssociatedParts ( _
	hostDocument As Document, _
	elementId As ElementId, _
	includePartsWithAssociatedParts As Boolean, _
	includeAllChildren As Boolean _
) As ICollection(Of ElementId)
Visual C++
public:
static ICollection<ElementId^>^ GetAssociatedParts(
	Document^ hostDocument, 
	ElementId^ elementId, 
	bool includePartsWithAssociatedParts, 
	bool includeAllChildren
)

Parameters

hostDocument
Type: Autodesk.Revit.DB..::..Document
The document of the element.
elementId
Type: Autodesk.Revit.DB..::..ElementId
The element to be checked for associated Parts.
includePartsWithAssociatedParts
Type: System..::..Boolean
If true, include parts that have associated parts.
includeAllChildren
Type: System..::..Boolean
If true, return all associated Parts recursively for all children. If false, only return immediate children.

Return Value

Parts that are associated to the element.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also