Constructs the vertex from a point, a normal vector, and a color.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public VertexPositionNormalColored( XYZ position, XYZ normal, ColorWithTransparency color ) |
Visual Basic |
---|
Public Sub New ( _ position As XYZ, _ normal As XYZ, _ color As ColorWithTransparency _ ) |
Visual C++ |
---|
public: VertexPositionNormalColored( XYZ^ position, XYZ^ normal, ColorWithTransparency^ color ) |
Parameters
- position
- Type: Autodesk.Revit.DB..::..XYZ
The vertex's position.
- normal
- Type: Autodesk.Revit.DB..::..XYZ
The vertex's normal vector.
- color
- Type: Autodesk.Revit.DB..::..ColorWithTransparency
The vertex's color.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |