Gets all specification identifiers in the fabrication configuration.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public IList<int> GetAllSpecifications( FabricationPart part ) |
Visual Basic |
---|
Public Function GetAllSpecifications ( _ part As FabricationPart _ ) As IList(Of Integer) |
Visual C++ |
---|
public: IList<int>^ GetAllSpecifications( FabricationPart^ part ) |
Parameters
- part
- Type: Autodesk.Revit.DB..::..FabricationPart
The fabrication part.
Return Value
An array of specification identifiers.
Remarks
If a part is passed, only returns specifications which are valid for the part, otherwise returns all specifications.