Gets a space containing the point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public Space GetSpaceAtPoint( XYZ point ) |
Visual Basic |
---|
Public Function GetSpaceAtPoint ( _ point As XYZ _ ) As Space |
Visual C++ |
---|
public: Space^ GetSpaceAtPoint( XYZ^ point ) |
Parameters
- point
- Type: Autodesk.Revit.DB..::..XYZ
Point to be checked.
Return Value
The space containing the point.
Remarks
Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns nullNothingnullptra null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the point is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue. |