Sets an aspect of the material to a shared property set.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetMaterialAspectByPropertySet( MaterialAspect aspect, ElementId propertySetId ) |
Visual Basic |
---|
Public Sub SetMaterialAspectByPropertySet ( _ aspect As MaterialAspect, _ propertySetId As ElementId _ ) |
Visual C++ |
---|
public: void SetMaterialAspectByPropertySet( MaterialAspect aspect, ElementId^ propertySetId ) |
Parameters
- aspect
- Type: Autodesk.Revit.DB..::..MaterialAspect
The material aspect.
- propertySetId
- Type: Autodesk.Revit.DB..::..ElementId
Identifier of a shared property set (an instance of PropertySetElement).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |