Creates a filter rule that determines whether strings from the document
are greater than or equal to a certain value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public static FilterRule CreateGreaterOrEqualRule( ElementId parameter, string value, bool caseSensitive ) |
Visual Basic |
---|
Public Shared Function CreateGreaterOrEqualRule ( _ parameter As ElementId, _ value As String, _ caseSensitive As Boolean _ ) As FilterRule |
Visual C++ |
---|
public: static FilterRule^ CreateGreaterOrEqualRule( ElementId^ parameter, String^ value, bool caseSensitive ) |
Parameters
- parameter
- Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
- value
- Type: System..::..String
The user-supplied string value against which values from the document will be compared.
- caseSensitive
- Type: System..::..Boolean
If true, the string comparison will be case-sensitive.
Remarks
For strings, a value is "greater" than another if it would appear after
the other in an alphabetically-sorted list.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |