Constructs a new instance of a DimensionEqualityLabelFormatting object with specified settings.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2017 Subscription Update
Syntax
C# |
---|
public DimensionEqualityLabelFormatting(
int leadingSpaces,
string prefix,
LabelType labelType,
string suffix,
FormatOptions formatOptions
) |
Visual Basic |
---|
Public Sub New ( _
leadingSpaces As Integer, _
prefix As String, _
labelType As LabelType, _
suffix As String, _
formatOptions As FormatOptions _
) |
Visual C++ |
---|
public:
DimensionEqualityLabelFormatting(
int leadingSpaces,
String^ prefix,
LabelType labelType,
String^ suffix,
FormatOptions^ formatOptions
) |
Parameters
- leadingSpaces
- Type: System..::..Int32
The number of spaces to include before the parameter value.
- prefix
- Type: System..::..String
The prefix to include before the parameter value.
- labelType
- Type: Autodesk.Revit.DB..::..LabelType
The parameter value to be shown.
- suffix
- Type: System..::..String
The suffix to include after the parameter value.
- formatOptions
- Type: Autodesk.Revit.DB..::..FormatOptions
The format options to use for the parameter value.
Exceptions
See Also