Defines bar deformation type.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public RebarDeformationType DeformationType { get; set; } |
Visual Basic |
---|
Public Property DeformationType As RebarDeformationType Get Set |
Visual C++ |
---|
public: property RebarDeformationType DeformationType { RebarDeformationType get (); void set (RebarDeformationType value); } |
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | When setting this property: None of the following disciplines is enabled: Structural. |