Checks if resolution of the failure using given resolution type is permitted.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2011

Syntax

C#
public bool IsFailureResolutionPermitted(
	FailureMessageAccessor failure,
	FailureResolutionType resolutionType
)
Visual Basic
Public Function IsFailureResolutionPermitted ( _
	failure As FailureMessageAccessor, _
	resolutionType As FailureResolutionType _
) As Boolean
Visual C++
public:
bool IsFailureResolutionPermitted(
	FailureMessageAccessor^ failure, 
	FailureResolutionType resolutionType
)

Parameters

failure
Type: Autodesk.Revit.DB..::..FailureMessageAccessor
Accessor to the failure to be resolved.
resolutionType
Type: Autodesk.Revit.DB..::..FailureResolutionType
Type of the failure resolution to be used.

Return Value

True if resolution of the failure using given resolution type is permitted.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException failure has not been properly initialized.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.Exceptions..::..InvalidOperationException This FailuresAccessor is inactive (is used outside of failures processing).

See Also