Get the id of the Rebar Coupler that is applied to the rebar at the specified end.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2009
Syntax
Visual Basic |
---|
Public Function GetCouplerId ( _
end As Integer _
) As ElementId |
Visual C++ |
---|
public:
ElementId^ GetCouplerId(
int end
) |
Parameters
- end
- Type: System..::..Int32
0 for the start Rebar Coupler, 1 for the end Rebar Coupler.
Return Value
The id of a Rebar Coupler, or invalidElementId if the rebar has
no Rebar Coupler at the specified end.
Exceptions
See Also