Checks if the reference provided can be used in creating Rebar constraints
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019.1
Syntax
C# |
---|
public bool IsReferenceValidForConstraint( Reference targetReference ) |
Visual Basic |
---|
Public Function IsReferenceValidForConstraint ( _ targetReference As Reference _ ) As Boolean |
Visual C++ |
---|
public: bool IsReferenceValidForConstraint( Reference^ targetReference ) |
Parameters
- targetReference
- Type: Autodesk.Revit.DB..::..Reference
The reference to be checked
Return Value
returns true if reference can be used in a constraint, false otherwise
Remarks
Reference is valid if it points to an uncut face of a structural that can host rebar.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |