Access reload information for out of date part.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019
Syntax
C# |
---|
public ReloadSwapOutInfo GetOutOfDatePartStatus( int index ) |
Visual Basic |
---|
Public Function GetOutOfDatePartStatus ( _ index As Integer _ ) As ReloadSwapOutInfo |
Visual C++ |
---|
public: ReloadSwapOutInfo^ GetOutOfDatePartStatus( int index ) |
Parameters
- index
- Type: System..::..Int32
The index of the information about the part being reloaded. Must be between 0 and OutOfDatePartCount.
Return Value
Information about the part being reloaded.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The index is out of range. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |