A non-negative real number specifying the minimum allowed angle for any triangle in the triangulation, in radians.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public double MinAngleInTriangle { get; set; } |
Visual Basic |
---|
Public Property MinAngleInTriangle As Double Get Set |
Visual C++ |
---|
public: property double MinAngleInTriangle { double get (); void set (double value); } |
Remarks
A small value can be useful when triangulating long, thin objects, in order to keep the number of triangles
small, but it can result in long, thin triangles, which are not acceptable for all applications. If the value
is too large, this constraint may not be satisfiable, causing the triangulation to fail. This constraint may be
approximately enforced. A value of 0 means to ignore the minimum angle constraint.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The given value for minAngleInTriangle must be at least 0 and less than 60 degrees, expressed in radians. The value 0 means to ignore the minimum angle constraint. |