Gets a DockablePane object by its ID.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public DockablePane GetDockablePane( DockablePaneId id ) |
Visual Basic |
---|
Public Function GetDockablePane ( _ id As DockablePaneId _ ) As DockablePane |
Visual C++ |
---|
public: DockablePane^ GetDockablePane( DockablePaneId^ id ) |
Parameters
- id
- Type: Autodesk.Revit.UI..::..DockablePaneId
Unique identifier for the new pane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if no dockable pane has been registered with identifier %id%. |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the dockable pane with identifier %id% has not been created yet. |