IFC transactions are context-like objects that guard any changes made to an IFC file.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public class IFCTransaction : IDisposable |
Visual Basic |
---|
Public Class IFCTransaction _ Implements IDisposable |
Visual C++ |
---|
public ref class IFCTransaction : IDisposable |
Remarks
Any change to an IFC file can only be made while there is an active transaction
open for that file. Changes do not become a part of the file until the
active transaction is committed. Consequently, all
changes made in a transaction can be rolled back
either explicitly or implicitly (by the destructor).
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB.IFC..::..IFCTransaction
Autodesk.Revit.DB.IFC..::..IFCTransaction