Retrieves a box that circumscribes the solid geometry.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public BoundingBoxXYZ GetBoundingBox() |
Visual Basic |
---|
Public Function GetBoundingBox As BoundingBoxXYZ |
Visual C++ |
---|
public: BoundingBoxXYZ^ GetBoundingBox() |
Remarks
The bounding box information is stored as bounds in local coordinates and a transform.
So the transform is to be taken in to account when using the bounds.
This is different from the bounding box returned by Element.BoundingBox in that the bounding box
returned by that routine stores the bounds in modeling coordinates with an identity transform.