Creates a filter rule that determines whether strings from the document
do not equal a certain value.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2011
Syntax
C# |
---|
public static FilterRule CreateNotEqualsRule(
ElementId parameter,
string value,
bool caseSensitive
) |
Visual Basic |
---|
Public Shared Function CreateNotEqualsRule ( _
parameter As ElementId, _
value As String, _
caseSensitive As Boolean _
) As FilterRule |
Visual C++ |
---|
public:
static FilterRule^ CreateNotEqualsRule(
ElementId^ parameter,
String^ value,
bool caseSensitive
) |
Parameters
- parameter
- Type: Autodesk.Revit.DB..::..ElementId
A string-typed parameter used to get values from the document for a given element.
- value
- Type: System..::..String
The user-supplied string value against which values from the document will be compared.
- caseSensitive
- Type: System..::..Boolean
If true, the string comparison will be case-sensitive.
Exceptions
See Also