Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public bool IsAcceptableStartingView( ElementId viewId ) |
Visual Basic |
---|
Public Function IsAcceptableStartingView ( _ viewId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: bool IsAcceptableStartingView( ElementId^ viewId ) |
Parameters
- viewId
- Type: Autodesk.Revit.DB..::..ElementId
The Id of the element to check.
Return Value
True if the view is acceptable, False if it is not.
Remarks
Model views (such as plans, ceiling plans, sections, elevations, and 3d views) are acceptable.
In addition, drafting views, sheets, legends, schedules, and graphical column schedules are generally acceptable.
Special views such as the project browser, system navigator, reports, revision schedules, internal schedules,
sheets that are not actually in use, and views that belong to a family are not acceptable.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |