Gets the default parameter name that will be used when creating a key schedule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static string GetDefaultParameterNameForKeySchedule( Document document, ElementId categoryId ) |
Visual Basic |
---|
Public Shared Function GetDefaultParameterNameForKeySchedule ( _ document As Document, _ categoryId As ElementId _ ) As String |
Visual C++ |
---|
public: static String^ GetDefaultParameterNameForKeySchedule( Document^ document, ElementId^ categoryId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to which the new schedule will be added.
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
The ID of the category of elements that the schedule's keys will be associated with.
Return Value
The default parameter name.
Remarks
See ViewSchedule.KeyScheduleParameterName for details.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |