Constructs a new instance of an ElementParameterFilter from a single rule.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public ElementParameterFilter( FilterRule filterRule ) |
Visual Basic |
---|
Public Sub New ( _ filterRule As FilterRule _ ) |
Visual C++ |
---|
public: ElementParameterFilter( FilterRule^ filterRule ) |
Parameters
- filterRule
- Type: Autodesk.Revit.DB..::..FilterRule
The rule applied to test if the element passes this filter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |