Adds element ids to the connection. All element ids in an array should be of applicable category.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public void AddElementIds(
	IList<ElementId> elemIds
)
Visual Basic
Public Sub AddElementIds ( _
	elemIds As IList(Of ElementId) _
)
Visual C++
public:
void AddElementIds(
	IList<ElementId^>^ elemIds
)

Parameters

elemIds
Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
The ElementIdArr containing ids of elements to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException One or more element ids was not permitted to be add to the connection. Elements should be of applicable category. -or- One or more element ids was not permitted to be added to the connection. Elements should not be duplicated.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also