Change the sequence of points interpolated by this curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetPoints( ReferencePointArray points ) |
Visual Basic |
---|
Public Sub SetPoints ( _ points As ReferencePointArray _ ) |
Visual C++ |
---|
public: void SetPoints( ReferencePointArray^ points ) |
Parameters
- points
- Type: Autodesk.Revit.DB..::..ReferencePointArray
An array of 2 or more ReferencePoints.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together. |