Sets a group of user-created worksets to open.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public void Open( IList<WorksetId> worksetsToOpen ) |
Visual Basic |
---|
Public Sub Open ( _ worksetsToOpen As IList(Of WorksetId) _ ) |
Visual C++ |
---|
public: void Open( IList<WorksetId^>^ worksetsToOpen ) |
Parameters
- worksetsToOpen
- Type: System.Collections.Generic..::..IList<(Of <(<'WorksetId>)>)>
The group of user-created worksets to open. Non-user-created worksets and invalid workset ids will be ignored.
Remarks
Calling this method on a configuration created with options other than WorksetConfigurationOption.OpenAllWorksets will set these
worksets to be explicitly opened. If all worksets are set to open, the configuration will be unchanged. Worksets other than the inputs are unaffected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |