Constructs an instance of StructuralAsset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public StructuralAsset( string name, StructuralAssetClass structuralAssetClass ) |
Visual Basic |
---|
Public Sub New ( _ name As String, _ structuralAssetClass As StructuralAssetClass _ ) |
Visual C++ |
---|
public: StructuralAsset( String^ name, StructuralAssetClass structuralAssetClass ) |
Parameters
- name
- Type: System..::..String
The name of the asset.
- structuralAssetClass
- Type: Autodesk.Revit.DB..::..StructuralAssetClass
The type of structural material that this asset will describe.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |