Identifies if provided assembly members can be removed from the assembly instance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2012

Syntax

C#
public static bool CanRemoveElementsFromAssembly(
	AssemblyInstance assemblyInstance,
	ICollection<ElementId> memberIds
)
Visual Basic
Public Shared Function CanRemoveElementsFromAssembly ( _
	assemblyInstance As AssemblyInstance, _
	memberIds As ICollection(Of ElementId) _
) As Boolean
Visual C++
public:
static bool CanRemoveElementsFromAssembly(
	AssemblyInstance^ assemblyInstance, 
	ICollection<ElementId^>^ memberIds
)

Parameters

assemblyInstance
Type: Autodesk.Revit.DB..::..AssemblyInstance
The assembly instance to remove elements from.
memberIds
Type: System.Collections.Generic..::..ICollection<(Of <(<'ElementId>)>)>
Element ids to be tested for validity to remove from the assembly instance.

Return Value

True if all member ids are valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also