Returns a collection of leaf FolderItemInfo objects each containing the given element Id.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public IList<FolderItemInfo> GetFolderItems( ElementId elementId ) |
Visual Basic |
---|
Public Function GetFolderItems ( _ elementId As ElementId _ ) As IList(Of FolderItemInfo) |
Visual C++ |
---|
public: IList<FolderItemInfo^>^ GetFolderItems( ElementId^ elementId ) |
Parameters
- elementId
- Type: Autodesk.Revit.DB..::..ElementId
Element id located at a leaf position in the project browser.
Return Value
An array of FolderItemInfo objects.
Remarks
Each returned FolderItemInfo includes the folder name and the corresponding folder parameter Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | elementId is not a valid Element identifier. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |