This method is called when a Point is being output.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
RenderNodeAction OnPoint( PointNode node ) |
Visual Basic |
---|
Function OnPoint ( _ node As PointNode _ ) As RenderNodeAction |
Visual C++ |
---|
RenderNodeAction OnPoint( PointNode^ node ) |
Parameters
- node
- Type: Autodesk.Revit.DB..::..PointNode
An output node that represents a Point.
Return Value
Return RenderNodeAction.Proceed if you wish to receive low-level geometry (line segments) for this point, or otherwise return RenderNodeAction.Skip.
Remarks
Note that this method is invoked only if the custom exporter
was set up to include geometric objects in the output stream.
See IncludeGeometricObjects for mode details.