Gets the PlanTopologies of the current project in a given phase.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public PlanTopologySet this[ Phase phase ] { get; } |
Visual Basic |
---|
Public ReadOnly Property PlanTopologies ( _ phase As Phase _ ) As PlanTopologySet Get |
Visual C++ |
---|
public: property PlanTopologySet^ PlanTopologies[Phase^ phase] { PlanTopologySet^ get (Phase^ phase); } |
Parameters
- phase
- Type: Autodesk.Revit.DB..::..Phase
The phase of the Plan Topology.
Remarks
Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet.
The time necessary for the calculations may be significant and should be considered.