Provides access to the string contents of the given family parameter.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public string AsString( FamilyParameter familyParameter ) |
Visual Basic |
---|
Public Function AsString ( _ familyParameter As FamilyParameter _ ) As String |
Visual C++ |
---|
public: String^ AsString( FamilyParameter^ familyParameter ) |
Parameters
- familyParameter
- Type: Autodesk.Revit.DB..::..FamilyParameter
Return Value
The string contained in the parameter. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the storage type of the input argument is not string type or this parameter has no value.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input argument-"familyParameter"-is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown if the input argument-"familyParameter"-is invalid, |