Gets all the Building Constructions corresponding to the specific Construction type.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public ICollection<Construction> GetConstructions( ConstructionType constructionType ) |
Visual Basic |
---|
Public Function GetConstructions ( _ constructionType As ConstructionType _ ) As ICollection(Of Construction) |
Visual C++ |
---|
public: ICollection<Construction^>^ GetConstructions( ConstructionType constructionType ) |
Parameters
- constructionType
- Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The Construction Type of Building Construction.
Return Value
A collection containing Building constructions matching the construction type.
Remarks
This function is used to get the Building Construction of the Project Information.