Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public IList<ReferenceWithContext> Find( XYZ origin, XYZ direction ) |
Visual Basic |
---|
Public Function Find ( _ origin As XYZ, _ direction As XYZ _ ) As IList(Of ReferenceWithContext) |
Visual C++ |
---|
public: IList<ReferenceWithContext^>^ Find( XYZ^ origin, XYZ^ direction ) |
Parameters
- origin
- Type: Autodesk.Revit.DB..::..XYZ
The origin of the ray.
- direction
- Type: Autodesk.Revit.DB..::..XYZ
The direction of the ray.
Return Value
A collection containing the intersected references.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |