Constructs a new instance of PushButtonData.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public PushButtonData(
string name,
string text,
string assemblyName,
string className
) |
Visual Basic |
---|
Public Sub New ( _
name As String, _
text As String, _
assemblyName As String, _
className As String _
) |
Visual C++ |
---|
public:
PushButtonData(
String^ name,
String^ text,
String^ assemblyName,
String^ className
) |
Parameters
- name
- Type: System..::..String
The internal name of the new button.
- text
- Type: System..::..String
The user visible text seen on the new button.
- assemblyName
- Type: System..::..String
The assembly path of the button.
- className
- Type: System..::..String
The name of the class containing the implementation for the command.
Exceptions
See Also