An object that can be used to create new instances of Autodesk Revit API elements
within a family document.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FamilyItemFactory FamilyCreate { get; } |
Visual Basic |
---|
Public ReadOnly Property FamilyCreate As FamilyItemFactory Get |
Visual C++ |
---|
public: property FamilyItemFactory^ FamilyCreate { FamilyItemFactory^ get (); } |
Field Value
This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the current document is project document. |