Gets the area for this polygon.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public double ComputeArea() |
Visual Basic |
---|
Public Function ComputeArea As Double |
Visual C++ |
---|
public: double ComputeArea() |
Return Value
The area for this polygon.
Remarks
The area of the planar non-self-intersecting polygon computed as:
A = 1/2 * (X1 Y2) - (X2 Y1) + ... + (Xn Y1) - (X1 Yn)