Returns the selected file path chosen by the user.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public ModelPath GetSelectedModelPath()
Visual Basic
Public Function GetSelectedModelPath As ModelPath
Visual C++
public:
ModelPath^ GetSelectedModelPath()

Return Value

The selected file path, or nullNothingnullptra null reference (Nothing in Visual Basic) if the dialog has not been shown or selection was cancelled.

See Also