Gets the collection of externally added items that the user opted to enable for transfer in the Transfer Project Standards dialog.
Namespace: Autodesk.Revit.UI.EventsAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017.2
Syntax
C# |
---|
public IDictionary<Guid, string> GetSelectedExternalItems() |
Visual Basic |
---|
Public Function GetSelectedExternalItems As IDictionary(Of Guid, String) |
Visual C++ |
---|
public: IDictionary<Guid, String^>^ GetSelectedExternalItems() |
Return Value
External items user wants to transfer.
Remarks
If more than one add-in has registered external items, this will report items enabled for transfer for all such add-ins. Add-ins should handle the transfer only for those items which they actually registered in the TransferringProjectStandards event.