Returns an interface providing access to free-form properties and methods for this Rebar element.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public RebarFreeFormAccessor GetFreeFormAccessor() |
Visual Basic |
---|
Public Function GetFreeFormAccessor As RebarFreeFormAccessor |
Visual C++ |
---|
public: RebarFreeFormAccessor^ GetFreeFormAccessor() |
Return Value
The interface providing access to free-form properties and methods for this Rebar element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | This method applies only to free form rebar. |