Sets path information identifying where Revit searches for content.
Namespace: Autodesk.Revit.ApplicationServicesAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public void SetLibraryPaths( IDictionary<string, string> paths ) |
Visual Basic |
---|
Public Sub SetLibraryPaths ( _ paths As IDictionary(Of String, String) _ ) |
Visual C++ |
---|
public: void SetLibraryPaths( IDictionary<String^, String^>^ paths ) |
Parameters
- paths
- Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The map of library paths.
Remarks
The map that
is returned should contain a key that is purpose of the path, such as Material Libraries and the value
in the map is the fully qualified path to be used for that search path.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |