Gets the Revision Number for a RevisionCloud on this sheet.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2015

Syntax

C#
public string GetRevisionCloudNumberOnSheet(
	ElementId revisionCloudId
)
Visual Basic
Public Function GetRevisionCloudNumberOnSheet ( _
	revisionCloudId As ElementId _
) As String
Visual C++
public:
String^ GetRevisionCloudNumberOnSheet(
	ElementId^ revisionCloudId
)

Parameters

revisionCloudId
Type: Autodesk.Revit.DB..::..ElementId
The id of the RevisionCLoud.

Return Value

Returns the Revision Number as it will appear on this sheet or nullNothingnullptra null reference (Nothing in Visual Basic) if there is no Revision Number assigned on this sheet.

Remarks

Returns nullNothingnullptra null reference (Nothing in Visual Basic) if the RevisionCloud or its associated Revision do not appear on this sheet. The Revision Number for a RevisionCloud will always be the same as the Revision Number of the associated Revision.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentException revisionCloudId is not the Id of a RevisionCloud.
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also