Sets the major layout pattern as FixedNumber, while specifying the needed parameters for this pattern.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2013
Syntax
C# |
---|
public void SetMajorLayoutAsFixedNumber(
double overallWidth,
double minorStartOverhang,
double minorEndOverhang,
int numberOfWires
) |
Visual Basic |
---|
Public Sub SetMajorLayoutAsFixedNumber ( _
overallWidth As Double, _
minorStartOverhang As Double, _
minorEndOverhang As Double, _
numberOfWires As Integer _
) |
Visual C++ |
---|
public:
void SetMajorLayoutAsFixedNumber(
double overallWidth,
double minorStartOverhang,
double minorEndOverhang,
int numberOfWires
) |
Parameters
- overallWidth
- Type: System..::..Double
The entire width of the wire sheet in the minor direction.
- minorStartOverhang
- Type: System..::..Double
The distance from the edge of the sheet to the first wire in the minor direction.
- minorEndOverhang
- Type: System..::..Double
The distance from the last wire to the edge of the sheet in the minor direction.
- numberOfWires
- Type: System..::..Int32
The number of the wires to set in the major direction.
Exceptions
See Also