Returns the graphic overrides assigned to elements in a particular workset.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public WorksharingDisplayGraphicSettings GetGraphicOverrides( WorksetId worksetId ) |
Visual Basic |
---|
Public Function GetGraphicOverrides ( _ worksetId As WorksetId _ ) As WorksharingDisplayGraphicSettings |
Visual C++ |
---|
public: WorksharingDisplayGraphicSettings^ GetGraphicOverrides( WorksetId^ worksetId ) |
Parameters
- worksetId
- Type: Autodesk.Revit.DB..::..WorksetId
The workset id of interest. This must be a user workset.
Return Value
Returns the graphic overrides assigned to the workset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | worksetId does not correspond to a user workset in the document containing this WorksharingDisplaySettings. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |