Gets orientation type of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static AdaptivePointOrientationType GetPointOrientationType( Document doc, ElementId refPointId ) |
Visual Basic |
---|
Public Shared Function GetPointOrientationType ( _ doc As Document, _ refPointId As ElementId _ ) As AdaptivePointOrientationType |
Visual C++ |
---|
public: static AdaptivePointOrientationType GetPointOrientationType( Document^ doc, ElementId^ refPointId ) |
Parameters
- doc
- Type: Autodesk.Revit.DB..::..Document
The Document
- refPointId
- Type: Autodesk.Revit.DB..::..ElementId
The ReferencePoint id
Return Value
Orientation type of Adaptive Placement Point.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |