Validates whether the combined parameters is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2021

Syntax

C#
public static bool IsValidCombinedParameters(
	Document aDocument,
	IList<TableCellCombinedParameterData> data
)
Visual Basic
Public Shared Function IsValidCombinedParameters ( _
	aDocument As Document, _
	data As IList(Of TableCellCombinedParameterData) _
) As Boolean
Visual C++
public:
static bool IsValidCombinedParameters(
	Document^ aDocument, 
	IList<TableCellCombinedParameterData^>^ data
)

Parameters

aDocument
Type: Autodesk.Revit.DB..::..Document
The document.
data
Type: System.Collections.Generic..::..IList<(Of <(<'TableCellCombinedParameterData>)>)>
The array of TableCellCombinedParameterData to be set as combined parameters.

Return Value

Returns true if the combined parameters are valid, and false otherwise.

Remarks

Currently the following parameters are supported:

  • Shared Parameters
  • RBS_ELEC_CIRCUIT_NAME
  • RBS_ELEC_CIRCUIT_PANEL_PARAM
  • RBS_ELEC_CIRCUIT_TYPE
  • CIRCUIT_LOAD_CLASSIFICATION_ABBREVIATION_PARAM
  • RBS_ELEC_CIRCUIT_NAMING_INDEX
  • RBS_ELEC_NUMBER_OF_POLES
  • RBS_ELEC_CIRCUIT_RATING_PARAM
  • RBS_ELEC_CIRCUIT_FRAME_PARAM
  • RBS_ELEC_VOLTAGE
  • CIRCUIT_PHASE_PARAM
  • CIRCUIT_WAYS_PARAM
  • RBS_ELEC_CIRCUIT_SLOT_INDEX

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also