Returns all DirectContext3D handle types of the given category in the document.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public static ISet<ElementId> GetDirectContext3DHandleTypes( Document aDocument, ElementId handleCategory ) |
Visual Basic |
---|
Public Shared Function GetDirectContext3DHandleTypes ( _ aDocument As Document, _ handleCategory As ElementId _ ) As ISet(Of ElementId) |
Visual C++ |
---|
public: static ISet<ElementId^>^ GetDirectContext3DHandleTypes( Document^ aDocument, ElementId^ handleCategory ) |
Parameters
- aDocument
- Type: Autodesk.Revit.DB..::..Document
The document.
- handleCategory
- Type: Autodesk.Revit.DB..::..ElementId
A category of DirectContext3D handles.
Return Value
The set of DirectContext3D handle types of the given category.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | the category ID handleCategory is not valid for DirectContext3D handles. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |