An enumerated type listing possible LineType scaling modes.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum LineScaling |
Visual Basic |
---|
Public Enumeration LineScaling |
Visual C++ |
---|
public enum class LineScaling |
Members
Member name | Description |
---|---|
ViewScale | Exporting lines as they were scaled by view scale. This option preserves visual fidelity. |
ModelSpace | Modelspace scaling. LTSCALE is set to view scale and PSLTSCALE to 0. |
PaperSpace | Paperspace scaling. Specifies the value 1 for both LTSCALE and PSLTSCALE. |
Remarks
Whichever option is chosen, line type definitions are created so a dashed line always begins and ends with a dash.
Using these options does change the default behavior of exported DWGs. Some lines expected to be dashed may appear solid or in a different scale.