Creates a new instance of a Structural Connection Handler, which is defined by the elements to connect and the additional points.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2021
Syntax
C# |
---|
public static StructuralConnectionHandler Create( Document document, IList<ElementId> idsToConnect, ElementId typeId, IList<ConnectionInputPoint> additionalInputPoints ) |
Visual Basic |
---|
Public Shared Function Create ( _ document As Document, _ idsToConnect As IList(Of ElementId), _ typeId As ElementId, _ additionalInputPoints As IList(Of ConnectionInputPoint) _ ) As StructuralConnectionHandler |
Visual C++ |
---|
public: static StructuralConnectionHandler^ Create( Document^ document, IList<ElementId^>^ idsToConnect, ElementId^ typeId, IList<ConnectionInputPoint^>^ additionalInputPoints ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The Revit document.
- idsToConnect
- Type: System.Collections.Generic..::..IList<(Of <(<'ElementId>)>)>
List of element ids of connected elements.
- typeId
- Type: Autodesk.Revit.DB..::..ElementId
The type of Structural Connection Handler.
- additionalInputPoints
- Type: System.Collections.Generic..::..IList<(Of <(<'ConnectionInputPoint>)>)>
The array of points that help define the connection.
Return Value
The newly created connection.
Remarks
Elements should be of the following structural categories: framings (OST_StructuralFraming), columns (OST_StructuralColumns), walls (OST_Walls), floors (OST_Floors) or foundations (OST_StructuralFoundations).
The first of given elements is set as primary one.
The placement of the connection takes into account the additional definition points.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | It verifies that we have at least one element id in the list. -or- The type typeId is not a valid StructuralConnectionHandlerType. -or- Missing detailed structural connection service implementation. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). |
Autodesk.Revit.Exceptions..::..ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.Exceptions..::..ModificationOutsideTransactionException | The document has no open transaction. |