Hides the element group's attached detail groups of the input group type that
are compatible with the input view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2019.1
Syntax
C# |
---|
public void HideAttachedDetailGroups( View view, ElementId detailGroupTypeId ) |
Visual Basic |
---|
Public Sub HideAttachedDetailGroups ( _ view As View, _ detailGroupTypeId As ElementId _ ) |
Visual C++ |
---|
public: void HideAttachedDetailGroups( View^ view, ElementId^ detailGroupTypeId ) |
Parameters
- view
- Type: Autodesk.Revit.DB..::..View
The view that the attached detail groups must be compatible with.
- detailGroupTypeId
- Type: Autodesk.Revit.DB..::..ElementId
Only attached detail groups of this type will be hidden.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The attached detail group detailGroupTypeId does not match the input view's orientation. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The input group is not a model group and can therefore not have attached detail groups. |