Determines whether this structural asset is equal to another.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public bool Equals(
	StructuralAsset other
)
Visual Basic
Public Function Equals ( _
	other As StructuralAsset _
) As Boolean
Visual C++
public:
bool Equals(
	StructuralAsset^ other
)

Parameters

other
Type: Autodesk.Revit.DB..::..StructuralAsset
The structural asset with which to compare this structural asset.

Return Value

True if the given structural asset is equal to this one, otherwise false.

Exceptions

ExceptionCondition
Autodesk.Revit.Exceptions..::..ArgumentNullException A non-optional argument was NULL

See Also